29/9/10

Ubuntu + Firefox + Google Gears = no compatible - Solucionado!

Google Gears es un complemento para Firefox que amplía el navegador con el fin de crear una plataforma superior para aplicaciones web. Por ejemplo, permite almacenar en caché y proporcionar recursos de aplicaciones (HTML, JavaScript, imágenes, etc.) de forma local, y almacenar datos localmente en una base de datos relacional en la que se pueden realizar todo tipo de búsquedas, entre otras cosas.





Si bien es un gran complemento, la evolución tecnológica ha hecho que el equipo de desarrollo se pase a HTML5, como lo explican en el blog oficial, dejando de lado su soporte, que ha quedado en la versión 0.5.36.0 (0.5.35.0 en otras versiones).


Esta falta de soporte hace que no pueda utilizarse directamente en las últimas versiones de Ubuntu (9.10 y 10.04) afectando también a las últimas versiones de Firefox (3.5 y 3.6). Actualmente estoy utilizando Ubuntu 10.04 y Firefox 3.6.9.


La nueva solución

Instalar el paquete 'gears' desde el Centro de Software de Ubuntu.



La antigua solución

Se puede adaptar a diferentes versiones, modifcando el archivo.xpi original, tal como lo comentan en el foro de google gears.


Pero es más fácil instalar el instalador ya modificado por sampo.niskanen desde aquí.



Otros tags: ubuntu 10.04, firefox 3.6.9, google gears 0.5.36.0, linux_x86-gcc3, error ("Google Gears" no pudo instalarse porque no es compatible con el tipo de versión de Firefox (Linux_x86-gcc3). Por favor, póngase en contacto con el autor de este elemento acerca del problema.), ("Google Gears" could not be installed because it is not compatible with your Firefox build type (Linux_x86-gcc3). Please contact the author of this item about the problem.")

No hay comentarios:

Publicar un comentario